Skip Navigation

Este é o fórum de suporte técnico para o WPML — o plugin de WordPress multilíngue.

Todos podem ler, mas apenas clientes do WPML podem postar aqui. A equipe do WPML responde no fórum 6 dias por semana, 22 horas por dia.

This topic contains 7 respostas, has 2 vozes.

Last updated by Mateus Getulio 2 mes, 3 semanas atrás.

Assigned support staff: Mateus Getulio.

Autor Posts
maio 16, 2022 às 6:50 pm #11232541

herculesE

Hoje fiz a mudança os Links Permanentes do WooCommerce.

Antes: /produto/
Depois: /produtos/%product_cat%/

Após a mudança, os produtos dos idiomas Inglês e Espanhol pararam de funcionar.

Poderia me orientar em como consertar essa funcionalidade para que os produtos fiquem linkados nos 3 idiomas?

Meu site é hidden link

Screen Shot 2022-05-16 at 15.49.10.jpg
maio 17, 2022 às 6:37 pm #11241043

Mateus Getulio
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Olá,

Obrigado pelo seu contato e bem vindo ao nosso fórum de suporte!

Conferi algumas URLs em seu site, mas não consegui replicar o problema. Por exemplo:

hidden link e hidden link

Outro exemplo:

hidden link e hidden link

Por acaso conseguiu resolver o bug nesse meio tempo? Caso a resposta seja 'não', por favor nos forneça o passo a passo exato para replicar o problema. Além disso, eu vou solicitar temporariamente acesso ao seu site ( WP Admin e FTP ) para que possamos fazer o login e identificar o que está causando esse erro.

Você pode encontrar os campos necessários abaixo da seção de comentários, eles irão aparecer quando você for deixar a sua próxima resposta. A informação de acesso vai estar em um campo totalmente privado, apenas eu e você poderemos ver.

*** Caso seja necessário, eu posso instalar o Duplicator para fazer uma cópia do seu site e instala-la localmente no meu ambiente de testes? Isso é importante porque evitamos que as alterações e testes impactem no site principal (essa cópia será apagada tão logo resolvamos este problema).

*** Além disso, por favor faça o seu próprio backup completo do seu site antes de adicionar as suas credenciais.

Aqui neste link você pode encontrar mais informações sobre sua privacidade e segurança ao fornecer informações de debug para nosso suporte: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Aguardo seu retorno. Obrigado!

Atenciosamente,
Mateus.

maio 17, 2022 às 8:51 pm #11241795

Mateus Getulio
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Olá,

Obrigado por fornecer as credenciais de login.

Nós tentamos alguns métodos para migrar o website para uma cópia hospedada em nossos servidores, mas parece haver alguma restrição no servidor impedindo a conclusão da migração.

Seria possível que você gentilmente configure um staging website, onde possamos reproduzir o problema e tentar achar uma possível solução? Estou marcando sua próxima resposta como privada novamente, a fim de receber as informações de login solicitadas.

Grato desde já!

Cumprimentos,
Mateus.

maio 18, 2022 às 7:20 pm #11250459

Mateus Getulio
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Olá,

Obrigado por criar o ambiente de testes!

Realizei a mudança mencionada nos Permalinks, mas as traduções dos produtos ainda estão funcionando, ao que parece:

hidden link
hidden link

Faltou algum passo fundamental para replicar o problema? Nos conte por favor.

Aguardo seu feedback.

Cumprimentos,
Mateus.

maio 18, 2022 às 7:53 pm #11250565

herculesE

Estranho e porque no site principal deu erro?
Quando mudei os idiomas não abriam a página do produto e desconfigurou as urls das categorias também.

Poderia fazer essa alteração no site principal, para ver se consegue?

maio 18, 2022 às 8:18 pm #11250695

Mateus Getulio
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Olá,

Parece estar funcionando da mesma forma. Por exemplo:

hidden link
hidden link

hidden link
hidden link

Talvez tenha sido uma instabilidade temporária no servidor. Pode checar por favor e confirmar que está tudo certo? Obrigado!

Atenciosamente,
Mateus.

maio 18, 2022 às 8:31 pm #11250753

herculesE

Acho que agora funcionou porque eu desinstalei o plugin de cache. Acho que era isso.

Qualquer erro novamente eu te aviso.

maio 19, 2022 às 6:16 pm #11260247

Mateus Getulio
Supporter

Languages: Inglês (English ) Português (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Olá,

Obrigado pelo seu retorno.

Fico contente de saber que parece tudo resolvido agora. Por favor nos avise se o problema retornar em algum momento.

Cumprimentos,
Mateus.