Skip Navigation
0

WordPress 6.1 был выпущен 1 ноября и содержит критические проблемы с WPML. Недавно мы выпустили WPML 4.5.13 и String Translation 3.2.3, чтобы исправить эти недочеты.

WordPress 6.1 вносит серьезные изменения

Чтобы избежать поломки вашего сайта, вы должны обновить WPML 4.5.13 и String Translation 3.2.3 перед тем, как обновления до версии WordPress 6.1.

Как обновить WPML

WPML 4.5.13 и String Translation 3.2.3 теперь доступны для всех клиентов WPML. Вы можете получить эти обновления на странице Загрузки или на странице Плагины.

Обновление WPML и перевод строк

Что делать, если WordPress 6.1 ломает ваш сайт

Если вы обновите WordPress 6.1 до обновления WPML, на вашем сайте появится фатальная ошибка. Если вы уже пытались обновить WPML с помощью описанных выше шагов и не смогли, попробуйте воспользоваться следующим исправлением:

  1. Отключите перевод строк, чтобы сделать внешний интерфейс вашего сайта доступным для других пользователей.
  2. Обновите ядро WPML до версии 4.5.13 и String Translation до версии 3.2.3.
  3. Вновь включите функцию перевода строк.

Если вы не можете получить доступ к админке вашего сайта или ни один из предыдущих шагов не сработал, попробуйте воспользоваться одним из этих вариантов:

  • Обновите WPML вручную с помощью FTP (если вы не можете войти на свой сайт).
  • Откатитесь к предыдущей версии WordPress, затем обновите WPML.
  • Восстановите сайт из резервной копии, затем обновите WPML перед обновлением WordPress.
  • Используйте FTP для изменения имени папки плагина String Translation, что приведет к его деактивации. Затем вы можете удалить его со страницы плагинов и заново установить последнюю версию.

Как отключить автоматическое обновление функций WordPress в будущем

Вы можете отключить будущие автоматические обновления WordPress, за исключением обновлений обслуживания и безопасности, перейдя в DashboardUpdates и нажав на ссылку Switch to automatic updates for maintenance and security releases only.

Переход на автоматическое обновление только для выпусков по обслуживанию и безопасности WordPress

Важно отметить, что некоторые хостинг-провайдеры могут автоматически обновлять версии WordPress. В этом случае вам нужно будет связаться с ними, чтобы остановить автоматическое обновление.

Почему это произошло

Этот выпуск WordPress был движущейся целью с изменениями, вносимыми между каждым кандидатом на выпуск, и ошибками, которые не были исправлены. Более того, дата релиза была праздничной для многих наших европейских клиентов и коллег.

Обычно мы не выпускаем обновление, пока оно не будет тщательно протестировано с последней версией WordPress. Однако из-за того, что до последней минуты не было доступно финальной версии WordPress 6.1, мы хотели как можно скорее предоставить вам обновление для критических проблем, о которых мы знали.

Известные проблемы в WordPress 6.1

Эти релизы WPML устраняют несколько известных проблем из WordPress 6.1, включая:

WPML Core 4.5.12 и 4.5.13:

  • Исправлено уведомление, связанное с WP_object_cache
  • Добавлена поддержка перевода нового блока List-item Gutenberg
  • Исправлена проблема с регистрацией строк, поступающих из контейнера Elementor Flexbox
  • Исправлена проблема, при которой текст виджета Block неожиданно обертывался тегом абзаца
  • Исправлена проблема, при которой переводы виджетов блоков больше не применялись
  • Исправлена проблема с переключателем языков меню, когда класс wpml-ls-first-item применялся к текущему языку, а не к первому языку из списка. Эта проблема появилась в WordPress 6.1 и WPML 4.5.12.
  • Исправлена проблема с иерархическими языковыми меню, чтобы исключить возможность не отображать текущий язык в таких меню.

String Translation 3.2.3:

  • Исправлена фатальная ошибка, возникающая при запуске WPML с WordPress версии 6.1.

Обратите внимание: в WordPress 6.1 могут возникнуть проблемы и с другими плагинами и темами. Обязательно обновляйте все темы и плагины, чтобы избежать проблем.

Вопросы или комментарии?

Сообщите нам об этом в разделе комментариев ниже, и мы ответим.

How can we make WPML better for you?

Share your thoughts and comments about our plugin, documentation, or videos by booking a Zoom call with Agnes, our Client Advocate. Your feedback matters and helps us improve.

Book a call with Agnes