Skip Navigation
Useful resources

YITH WooCommerce Terms and Conditions Popup is compatible with WPML. This plugin has been tested thoroughly, and you can use it to build multilingual sites without experiencing issues.

YITH WooCommerce Terms and Conditions Popup

— Developed by YITH

Version 1.0.0

Last tested on: 1 июня, 2015