Resolved in: 5.2.8

Topic Tags: Install and update


You might get the following PHP error if you are using a PHP version older than 5.6

Parse error: syntax error, unexpected T_CLASS, expecting T_STRING or T_VARIABLE or '$' in .../wp-content/plugins/sitepress-multilingual-cms/inc/functions.php on line 810


WPML now has a minimum required PHP version of 5.6.20, same as WordPress 5.2 and latest versions.

If you are hosting your WordPress installation in your own server configuration, please update your PHP version to 5.6.20 or preferably a newer one.

In case you are using a shared hosting plan, please ask your hosting provider to update your website’s PHP version.


If updating your server’s PHP version isn’t an option, you will have to rollback to the WPML 4.2.6 bundle.

This action will have to be done manually through FTP/SSH or any other way possible to access your site’s files.

First, download the respective versions of WPML Core, String Translation and Translation Management as described below:

  • WPML Core 4.2.6 – link
  • WPML String Translation 2.10.4 – link
  • WPML Translation Management 2.8.5 – link

If you are using WooCommerce Multilingual download the 4.6.5 version.

Next, you can replace your existing plugin files by simply deleting them and uploading the ones of the 4.2.6 release (your translations or any settings will not be lost as those are stored in the database). Read a more detailed guide on how to update manually here.