Skip Navigation
Useful resources

Advanced Ads is compatible with WPML. This plugin has been tested thoroughly, and you can use it to build multilingual sites without experiencing issues.

Advanced Ads

– Developed by Thomas Maier

Version 1.20.0

Last tested on: September 11, 2020

Ad Manager & AdSense