This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by jeroenS-7 1 month, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
September 2, 2019 at 4:02 pm

jeroenS-7

Hi,

When browsing through my website and switching between languages, I get an internal server error. This happens a lot.

When I save permalinks again, it is solved temporarily.

Do you have any idea how I can solve this?

Best regards,
Jeroen

September 2, 2019 at 9:26 pm #4500061

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Please, try the following steps:

1 - Make sure your current server environment meets our minimum requirements to run WPML. See: https://wpml.org/home/minimum-requirements/. You can see your current values in your WordPress Dashboard > WPML > Support.

2 - Disable all the plugins except the WPML related ones and try to reproduce the issue, if the issue doesn't happen, activate one plugin at a time untill the culprit one is found.

3 - Turn on your WP_DEBUG mode and try to reproduce the issue, then take a look at the error file and let me know if you see any meaningful info regarding this issue. See: https://wpml.org/documentation/support/debugging-wpml/

Please, let me know if it helps, have a nice day.

September 4, 2019 at 3:58 pm #4512723

jeroenS-7

My issue is resolved now. Thank you!