This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 28 replies, has 2 voices.

Last updated by Carlos Rojas 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 27, 2018 at 9:59 am #2677560

itzikE

Hi,

We have a problem with the decoding of some languages, and we think it's related to WPML.

The website in production(www.avapartner.com) is working fine, it save the translations as a symbols in the database, but when it use the translations on the website, it's transfer the symbols back to it's original characters.

Then we duplicated the production environment to a Dev environment, everything is the same, but now the Dev website is show us the symbols instead of the original characters of the language.
(image attached)

Thanks

August 27, 2018 at 8:43 pm #2679946

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Kind regards,
Carlos

August 28, 2018 at 2:56 pm #2683137

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

I was able to see the login page of the site, however I couldn't log in the site with the credentials provided. Could you double check the credentials provided and if necessary edit your previous (private) message?

Looking forward to your answer.
Best regards,
Carlos

August 29, 2018 at 7:18 am #2685208

itzikE

Hi Carlos,
I have provided you with the wrong details.
I need you to send me the IP you are coming from so I can open access to you.

For wp-admin access:
***

User: ***
Password: ***

For FTP access:
IP: ***
User: ***
Password: ***

August 29, 2018 at 7:19 am #2685210

itzikE

This is the correct debug info:
{"core":hment":1}}}}

August 29, 2018 at 8:47 am #2685565

itzikE

can you hide the IP and credentials details? tnx

August 29, 2018 at 3:46 pm #2687082

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

This is my IP address: 167.58.130.147

I hided the credentials you shared before and I set your next answer private so you can provide the credentials safetly.

Best regards,
Carlos

August 30, 2018 at 6:59 pm #2691684

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

However I'm still unable to see the site, it seems that my IPv4 changed to 167.58.175.139

In order to save time I would like to ask you to share a download link with a copy of the site. We usually recommend the free Plugin “Duplicator” for this porpoise.

If you already know how Duplicator works (http://wordpress.org/plugins/duplicator/),
please skip the following steps and just send me the installer file and the zipped package you downloaded.

★ Duplicator Instructions: hidden link

Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)

❌ IMPORTANT ❌
Remember to create or keep an admin account for me before creating the snapshot, or I won’t be able to login. You may delete the new admin account once the snapshot has been built.

I will enable your next answer as private so you can provide me the information securely.

Best regards,
Carlos

September 3, 2018 at 6:04 pm #2700691

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Yaniv,
Thank you very much for sharing a copy of the site.

I installed the copy of the site in local -> Updated the outdated plugins and themes and the issue is gone. (See attached image)

I would like to ask you to do the same steps I mentioned above and if necessary flush all cache memory that might exists. Could you tell me if the issue persists?

Best regards,
Carlos

September 4, 2018 at 9:46 am #2702631

itzikE

Hi Carlos,
our issue remains.

please see screenshot from wp-admin showing issues at WPML plugging - is this related to this?
When i click on "Detailed error log" it redirects me our production site hidden link (from which this server was cloned from) and not giving me any details.

Tnx Yaniv

September 4, 2018 at 6:47 pm #2704477

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Yaniv,

Could you confirm that you updated all outdated plugins in the site and flushed all cache memory and the issue persists?

If this is the case, i kindly ask you to double check the encoding of the database tables, maybe the cause of the issue is there.

Note: I tried to access the staging site but it seems that my IP changed again 🙁

Looking forward to your answer.
Best regards,
Carlos

September 5, 2018 at 8:17 am #2705851

itzikE

Hi Carlos,
Yes all the plugins are updated and we dont have any caching plugins.
yet we still see Gibberish in:
hidden link

If you want you can call me and I will open access to your IP at that very moment.
you can call me at:
+1.646.3350738 extension 2311

Tnx Yaniv

September 5, 2018 at 1:39 pm #2707353

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Yaniv,

In this link you will find the steps to follow in order to request a video call: https://wpml.org/2016/10/request-support-video-call/

Please follow the steps above and let me know if you need further assistance and I will be more than happy to help.
Best regards,
Carlos

September 6, 2018 at 7:36 am #2709725

itzikE

Hi Carlos,
I submitted a video call request as you said,
However i asked it for today but got a notice that I will be replied in 24-hours.
This is why I submitted another video call request for Sunday 06.09.2018

If you can please do the call today, if not I will wait for Sunday.

Tnx Yaniv

September 6, 2018 at 4:29 pm #2711708

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Yaniv,
Thank you very much for requesting the video call.

The specialists in charge of the videocall will choose the specialist who will do the call with you 🙂

If I'm selected for this I will be more than happy to do it.
Best regards,
Carlos