This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
Unable to translate fields with html tags using Advanced Translation editor

Solution:
While create the configuration file add the encoding to allow_html_tags

<attribute type="title" encoding="allow_html_tags ">link</attribute>

Relevant Documentation:
https://wpml.org/documentation/support/language-configuration-files/#page-builder-content

This topic contains 3 replies, has 2 voices.

Last updated by Shekhar Bhandari 3 months, 4 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
June 19, 2019 at 9:41 am #4050305

Orhan Erkut

Hello!

I’m using WPML with the Enfold. The main language page is English (hidden link) and the translated one Turkish (hidden link).

On the English page, you will see “Creative Solutions for your Corporate Colors.” text on the slider video. I translated it with WPML’s Advanced Translation Editor. I didn’t touch to html codes within that text block, but it is appearing like “Kurumsal Renkler <br>Yaratıcı Çözümler.”

What can be wrong with it?

Thank you,
Orhan

June 19, 2019 at 11:21 am #4051073

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Could you please install the latest version of Enfold theme here? hidden link

Once done I will continue testing the issue and will respond to you as soon as possible.

Look forward to your reply.

Thanks

June 19, 2019 at 11:24 am #4051109

Orhan Erkut

Thank you Shekhar,

I installed the latest version of the Enfold. I will be waiting for your reply.

Best wishes,
Orhan

June 20, 2019 at 3:53 am #4056407

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I recreated the situation and followed the below steps to fix the issue, so could you please follow the same steps and let me know if this helps:

1) Update WPML translation management to version 2.8.6.2
2) Add the following code to WPML->Settings->Custom XML Configuration

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>av_slide_full</tag>
            <attributes>
                <attribute encoding="allow_html_tags">title</attribute>
                <attribute type="link" encoding="av_link">link</attribute>
                <attribute>link1</attribute>
                <attribute>button_label</attribute>
                <attribute>button_label2</attribute>
                <attribute>link2</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

3) Go to WPML->Settings->Multilingual content setup and refresh the page.
4) Now translate the content, it will work properly.

You can also check how it's working on the sandbox site, hidden link

Let me know if this helps.

Thanks