2

This maintenance release fixes a number of incompatibilities between WPML and the greatest and bestest PHP – version 7.4. Now, if your web host offers, you can update your site to run on PHP 7.4 without bumping into compatibility issues with WPML.

PHP 7.4 offers preloading, which can significantly speed up sites. This allows WordPress and caching plugins to save a lot of time when loading pages (admin and front-end).

Besides the PHP 7.4 improvements, this version of WPML adds full support for translating Toolset websites created with the Block Editor.

We’ve also fixed a number of cosmetic glitches and removed an annoying message about REST API not working (the message was showing when it wasn’t the case).

How to update

As always, the easiest way to update your site is to receive the updates via the WordPress admin. You can always download the most recent version of WPML from your account.

Feedback? Questions?

Leave your comments and we’ll get back to you.

2 Responses to “WPML 4.3.6 Adds PHP 7.4 Compatibility for Faster Websites”

  1. Hi,
    As of yesterday my website had a complete French translation, my host is Bluehost, they deactivated my WPML plugin because of a critical error. Both Bluehost and I tried to reactivate, but not able to, and now my site has lost all of its second language “French”.

    Any suggestions?

    thank you

    • WPML plugin needs to be activated on your site in order for the translations to show. If WPML is inactive, only the site’s default language will display. We can help you troubleshoot why you are getting a fatal error when activating WPML. Please open a ticket in our support, give the details of the error and our supporters will help you resolve it.

      https://wpml.org/forums/forum/english-support/