Resolved

Reported for: WPML String Translation 2.7.3

Resolved in: 2.8.5

Topic Tags: String Translation

Symptoms

Elementor provides you with the possibility to create your own template on the Elementor -> My Templates admin page.

Let’s say that you have created one, you translate it using WPML and add it to a regular page. Now, you want to translate this page using our Translation editor. You would expect to see on it this translated content, however, this is not the case.

Workaround

At this moment our Compatibility team is working on this issue. However, as a temporary workaround, you can translate your template directly from the page again.

9 Responses to “Elementor libraries does not synchronise on Translation Editor”

  1. Hi,
    You mention Elementor “own template”
    Is translation editor still working with Elementor when using some specific templates ?

    Thank you,
    Alex

    • Yup. We have good progress. Now we received an important filter from Elementor and we’ll use it in WPML. We’ll write a separate blog post about the progress with Elementor. The plan is to allow two modes:

      1. Use the builder to design elements per language
      2. Design once with the builder and translate just the texts with WPML

      We’re going to handle both these translation modes in the very near future. When we have a beta, I’ll write about it and invite everyone to test and give us feedback.

  2. Hello everyone,

    We have release a new version WPML 4.0.5 which solves this issue.

    Please, create a full backup of your site and upgrade all your WPML package. Don’t hesitate to open a new ticket in our support forum if your problem remains.

    Regards