Skip Navigation

This topic contains 8 replies, has 3 voices.

Last updated by Itamar 2 years, 3 months ago.

Assigned support staff: Itamar.

Author Posts
October 8, 2018 at 9:34 pm #2797418

Arion Bizati

i have broke my website by trying to solve the page builder translation issue
i have follow documentation but im not sure what gone wrong
im not able to fix it. please help
here are some screenshot :
hidden link

everywhere show up [albanian] when i change language
even prices have [language]

Also have issue with wpbakery page builder- dont show slider for translation
i use theme page builder

October 9, 2018 at 6:40 am #2798381


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hello and thank you for contacting the WPML's Translation Support forum.

I'll try to help you with this issue. please answer these question so I'll have more information about this problem.

You are writing that you are using WPBakery page builder. But you are also writing that you are using the theme page builder.
1. Are you using two page builders to build your site or only WPBakery?
2. Have you followed this documentation?
3. What theme are you using?
4. What issue were you trying to solve that caused the problem?


October 9, 2018 at 10:53 am #2799601

Arion Bizati

sorry for my not clear explanation
im using only on wpbakery which comes with my theme- i use shopkeeper theme
im not using 2 page builders
the trouble its not at default languages but at translated languages as you can see from screenshot
and yes i have followed the instruction you have displayed
but im not familiar with coding and didnt know how to add short codes and i follow your documentation
and i think i broke with this plugin
for the last question-problem is that i have [language] everywhere- my prices at other languages are example [albanian]+price- [language]+title
so first trouble is to solve this [language]
second to solve wpbakery- to be able to translate sliders and other part build by wpbakery

October 9, 2018 at 12:10 pm #2799874

Arion Bizati

more information
i changed my theme- problem not solved with the second theme
i disable and enable wpml plugins- problem not solved
i disable woocommerce multilingual - problem not solved
i disable caching minifying - problem not solved

the trouble is [language] everywhere like in the screen shot:
hidden link
hidden link

the second trouble:
hidden link
i have read and follow instruction from documentation
and there is enabled translation for page builder

third trouble i have error message:
hidden link
i follow documentation and rewrite its enabled
hidden link

hope this additional information help you to understand what exactly its the problem
also im ready to give you temporary access to my website with giving username and password- just let me know how can i send this information to you

October 10, 2018 at 9:54 am #2803725


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thanks for the extra details.

Issue number 1.

The [language] issue was most probably caused by you activating and running the Multilingual Tools Plugin. We have a warning on the plugin's documentation page that this should not be implemented on production sites.

This tool produces a duplicate of the original content appended with the language code and modifies any existing translations; therefore, you should never run it on production or client sites.

The options that you have now are the following.

A. Delete the second language and retranslate the site -> This is a good option if you do not have a lot of content.

B. Perform a DB operation to replace [language] with a blank string using some DB search and replace tool like this.
hidden link
This option requires some knowledge and understanding in DB and the tool that you are using. In any case, you better take a DB backup before doing that.

C. Restore your site from backup before you have used this tool and the problem started.
In this case, you will lose any content that you might have added after that restored backup.
EDIT: D. Please also see the solution that is suggested here (top yellow section).
Click on the Multilingual Tools > Settings. - Select the desired languages - Remove the "[%language_code%]" - Keep only the "%original_string%" on the template field - Click on the "Generate strings translations" button.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Issue number 2.
The theme and WPBakery issue.

Are you using this theme?
hidden link
Is it the default WPBakey slider that is missing for translation in the Translation Editor?

Issue number 3.
The language in directories error message.
When I check your site here hidden link it seems that languages in directories do work. Sometimes the message shows when actually it does work.
Please try to re-save the permalinks in Settings -> Permalinks and then re-save the setting for the Language URL format and see if the error disappears.

If you are going to need more help from me, then it is important for me to mention that we are communicating here in the translation support forum. This forum is intended for 'how to translate' issues to end users who are clients of our clients. If you have purchased WPML CMS package, then we'll be able to continue helping you with the issues that you are having on your site, if you open a ticket in our technical support forum here Please open one ticket per issue.
Otherwise, from the information that I have here, our customer is the user @edwardh-9 which is the developer who developed for you this site (hidden link). I'm currently adding @edwardh-9 to the conversation here so he can better help you with the issues here. It can also be good if you contact him directly and send him the link to this ticket.

Best Regards,

October 10, 2018 at 10:29 am #2803851

Arion Bizati

Second issue
yes i use shopkeeper theme you mention before
third issue
i have saved permalinks- its mention in your documentation
but error message still there

if i use backup file issue 2 and 3 its not going to be solved

look like i dont have access to technical support
i need to contact developer to open ticket for me ?

October 10, 2018 at 10:57 am #2803926


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)


I've invited @edwardh-9 to join this conversation. He supposes to get an email about it.
You can mention it to him/her as well. If needed, he/she (as our client) will be able to open a ticket in our support forum.


October 10, 2018 at 11:31 am #2803975


I will be opening a ticket in support for this thank you Itamar for your help and suggestions.

October 10, 2018 at 8:38 pm #2805763


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Thanks, @edwardh-9.

Please open a ticket per issue. This way it will be easier for us to handle those issues.

Best Regards,

The topic ‘[Closed] broken website’ is closed to new replies.