This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Lauren 1 year, 5 months ago.

Assigned support staff: Lauren.

Author Posts
April 23, 2018 at 5:05 pm #1774079

mohammad-rezaT

We have a site that enable multi language with your plugin, everything is normal in test server but when we switch in production and visitors raise approximately to 500 person the site load speed decrease and finally some visitors get timeout. Afrer disable your plugin everything back to normal state
Regards

April 23, 2018 at 9:07 pm #1776852

mohammad-rezaT

I provide Debug object log file, you can see in pastebin.con:
https://pastebin.com/3tu5Spcu
https://pastebin.com/QPvvkChH
https://pastebin.com/YCf7MnS9

April 24, 2018 at 6:19 pm #1795524

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this. I understand you are having site performance issues. Since performance issues can be difficult to pinpoint, let's check a few variables and settings to narrow the issue. Please answer as many of these questions as you can. Contact your hosting provider, if necessary.

Do you have different domains per languages? If so, please disable auto sign-in and sign-out users from all domains which is under WPML -> Languages -> URL Format.

Next, please keep WPML & all related plugins enabled while we do these steps:

1. The WP Memory Limit may need to be increased. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

2. Can you add debug information to the thread? Instructions: https://wpml.org/faq/provide-debug-information-faster-support/

3. If you haven't already, can you review the following article https://wpml.org/2012/01/can-your-site-run-faster/ to ensure all relevant steps are followed?

4. Can you confirm that the following settings are OFF or disabled:
- Adjust IDs for multilingual functionality (WPML > Languages)
- Track where strings appear (WPML > String translation)
- Auto register strings(WPML > String translation)

5. Can you tell me more information about the hardware including the CPU?

6. What type of hosting do you have? Shared, VPS, Dedicated, etc?

7. Do you know if object caching is part of your PHP setup? PHP < 5.5 should be APC. Newer versions should use the zend op cache, uAPC will also work though but is slower.

8. Can you confirm that you are still experiencing performance issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Fifteen) ?

9. Are you using a cache plugin?

10. Make sure Disk caching is disabled.

11. Try disabling the total cache plugin.

Thank you for helping us pinpoint the issue. Feel free to add any other information you may have.

April 24, 2018 at 6:45 pm #1795682

mohammad-rezaT

Hi
Please see the following, I am going to answer your questions:
1. The WP Memory Limit may need to be increased.
It's set correctly
X_MEMORY_LIMIT', '256M' );

2. Can you add debug information to the thread?
I added to this reply

3. If you haven't already, can you review the following article https://wpml.org/2012/01/can-your-site-run-faster/ to ensure all relevant steps are followed?
I read this article before post this ticket. Except wp cash, everything has done.

4. Can you confirm that the following settings are OFF or disabled:
- Adjust IDs for multilingual functionality (WPML > Languages)
- Track where strings appear (WPML > String translation)
- Auto register strings(WPML > String translation)
Yes, I confirm those

5. Can you tell me more information about the hardware including the CPU?
We have a dedicated host with 32GB of RAM and 32 Core CPU, please note that our web server is Nginx. Also, DB Server dedicates from the web server.

6. What type of hosting do you have? Shared, VPS, Dedicated, etc?
Dedicate one.

7. Do you know if object caching is part of your PHP setup? PHP < 5.5 should be APC. Newer versions should use the zend op cache, uAPC will also work though but is slower.
object cashing was not set up

8. Can you confirm that you are still experiencing performance issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Fifteen) ?
Please ensure that I spent a lot of time and found the problem generate by WPML and after all post the ticket
9. Are you using a cache plugin?
NO
10. Make sure Disk caching is disabled.
Sure that is disabled
11. Try disabling the total cache plugin.
I never use this
Thank you for your support

April 24, 2018 at 6:50 pm #1795688

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

May 2, 2018 at 2:42 pm #1936134

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please provide me access to your testing site so that our 2nd tier developers can look further into this. The next reply is marked as private so you can securely share this information.

May 4, 2018 at 12:26 pm #1974901

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending credentials. I have escalated this ticket to our 2nd Tier Support team. As soon as I have more information, I will update there.

May 15, 2018 at 4:02 pm #2144156

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Our developers are having a difficult time troubleshooting because they have not been able to reproduce this issue. We cannot test this in our server because 1) We don't have the way to simulate 500 visitors online 2) we cannot deploy the duplicator ( if I remember correctly is about 14Gb) I have some additional questions that will help us continue troubleshooting.

1. How are you finding that this is happening when you have 500 users online?
2. How are you testing the performance? Fore example, is it with google analytics and the real-time feature?
3. Also, are all the 500 users doing the same thing?
4. Which page are you getting the timeout and how is this tested?

Previously I had asked you to test with auto registering strings deactivated. However, recently our developers have found that there has actually been an increase in performance when this is activated. Can you please test registering all domains for auto string registration and let me know if there is any difference (good or bad) after this change? Please see https://wpml.org/faq/why-string-translation-appears-to-slow-down-sites/

Another solution will be to test our new beta version once it is available, and I would recommend this in a staging environment. I will let you know once it is available for download.

The topic ‘[Closed] Low speed site load’ is closed to new replies.