This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by George Botsev 1 year ago.

Assigned support staff: Noman.

Author Posts
September 24, 2018 at 12:39 pm #2760443

Reinhard

I am trying to: Update WP, Avada and WPML

Link to a page where the issue can be seen:

hidden link (with htaccess)

I expected to see:

Working WP Backend

Instead, I got:

No working WP Backend

I will not give you all the Passwords for htaccess, DB, SFTP and WP-Admin in advance. If you need some of them, please tell me.

September 25, 2018 at 11:14 am #2763472

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Please follow this post - https://wpml.org/forums/topic/wpml-is-telling-me-that-it-has-a-broken-table-that-needs-fixing/ if the described fix does not work for you please leave your details and George (who's handling these cases) will take a look at your site and tell you what you need to do.

Thank you

September 25, 2018 at 12:18 pm #2763686

Reinhard

Hello Noman / George,

Do you mean the Workaround with the wpml_fix_missing_icl_tables function?
I tried this a few days ago with no postive result.

Regards, Reinhard

September 25, 2018 at 3:52 pm #2764623

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Yes, I was trying to refer to that fix, that’s ok if that fix does not make any change. To further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

October 2, 2018 at 6:58 pm #2782552

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello,

I have debug this issue, I enabled debug mode but there is no php errors shown. I also installed WPML plugin again but the problem still exists.

So we need to patch your database now, please follow instructions on this post and send your site’s database dump and needed info there, our concerned team member will download it and provide patch for your site:
https://wpml.org/forums/topic/wpml-is-telling-me-that-it-has-a-broken-table-that-needs-fixing/page/152/#post-2685073

Thank you

October 4, 2018 at 9:04 am #2786837

Reinhard

Hello Noman,
in my last Private Message was a Link to the PMA with the actual DB. Maybe this is better for you.
You can also Download the Dump here: hidden link It's behind a htaccess with the same Data, i provided you.
Regards, Reinhard

October 4, 2018 at 6:23 pm #2788538

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for sending DB dump. I have forwarded it to George who is handling the patch fix for this issue. Here is the message I have posted, please check here:
https://wpml.org/forums/topic/wpml-is-telling-me-that-it-has-a-broken-table-that-needs-fixing/page/162/#post-2788526

October 5, 2018 at 8:46 am #2789909

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Hello!
I checked your database.
You are affected by a false-positive.
I tried to visit your site, but I was unable to visit it - the host did not respond to my browser.
I successfully visited your site database.
I went there and removed the key "wpml_string_table_ok_for_mo_import" from the option table. That is a key which should contain a specific value and is regenerated after visiting the backend.
If everything is alright, next time when you visit the backend, that key will be regenerated automatically in your options table and you should not see anymore the notice for the problem with the database.

Please let me know how it goes and if the problem persists - please allow me to check your site and patch the problem directly.

The topic ‘[Closed] There is a problem with the String Translation table in your site….’ is closed to new replies.