This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Mihai Apetrei 1 month, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
August 13, 2019 at 12:44 pm

exis

I am trying to:
Install WPML and translate pages already created. The current pages are in English and we need to setup WMPL for Greek as well

I expected to see:
After installing I expected to see the translation manager when hitting the plus icon next to the original pages

Instead, I got:
An empty page

I have provided access so that you login, activate WPML and run the installation in order to replicate the issue. When prompted select English as the default and content language.

In other languages select Greek.

August 13, 2019 at 3:24 pm #4389205

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

From what I can see in the backend of the site, WPML is currently disabled.

Can you please enable it and try to translate a page and send me a screenshot of the error that you are experiencing or a screen-recording?

I will be waiting for your response.

Kind regards,
Mihai Apetrei

August 13, 2019 at 3:44 pm #4389325

exis

We have left it disabled in order for you to enable it and see the issue. We have reset the database, that is why it is disabled.

thanks!

August 13, 2019 at 6:26 pm #4390299

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the confirmation, I did not know that.

I am at the end of my shift for the moment but I will get back to you tomorrow after I spend more time on this.

I am leaving the ticket assigned to myself for the moment.

Kind regards,
Mihai

August 14, 2019 at 8:45 pm #4397447

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I installed WPML once again but it seems that you still need to add the key to register it.

You can go here to generate it (https://wpml.org/account/sites/).

Here is more info on how you can generate a key for a domain:
https://wpml.org/faq/install-wpml/#register

After you do that, can you please let me know if you are able to follow the documentation in order to translate content with WPML:
https://wpml.org/documentation/getting-started-guide/#how-to-translate-pages-posts-and-custom-posts

Also, please don't forget to activate WPML String Translation and WPML Translation Management if you want to translate any plugin/theme strings or content created with a page builder.

If something doesn't work as expected, can you please let me know what did not work so that I can further investigate?

If you have a screenshot or a screen recording to share, that would be really helpful, too.

I will be waiting for your response.

Kind regards,
Mihai

August 14, 2019 at 8:59 pm #4397521

exis

Just activated and although the default language is English the website language is in Greek.

All the content is marked as Greek, even though we have selected that the default content language is English.

Also we cannot translate any page using the translation manager

August 14, 2019 at 9:50 pm #4397763

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for adding the registration key.

1. Can you please let me know what do you mean when you say "although the default language is English the website language is in Greek"?

2. Can you please let me know what do you mean when you say "All the content is marked as Greek"?

3. It seems that the WPML String Translation and WPML Translation Management plugins were disabled so I think that was the reason why you could not use the Translation Editor (also it seems that there is an update for the WPML TM plugin so I recommend that you update it when you have time).

Also, you can choose how to translate posts and pages by going to the WPML > Settings > "How to translate posts and pages" section - you can select if you want to use ATE (Advanced Translation Editor) or CTE (WPML Classic Translation Editor).

I hope that you will find this information helpful and I am still waiting for an answer for the first 2 questions above.

Kind regards,
Mihai

August 15, 2019 at 6:16 am #4399203

exis

The pages were created in English

We have installed WPML as we normally do on all of our installations

When running the installer we have selected that the default content is in English

We have selected greek as the additional language

When the installation finished we went to the pages and although we have set that the default WPML language is greek, the permalinks on the website are ?lang= el

That is why we have disabled the WPML plugin, reset the dB and asked you to run the installation

As you can see the pages on the WordPress dashboard are mixed up. Half of them are marked as greek and others as English

Also when clicking on the plus icon the translation manager does not work.

Hope this clears things up.

We can reset the database and you can run the installation yourself as we have asked when opening this ticket. Use a register key or ask us to provide one from our account.

How do you want to proceed?

August 15, 2019 at 6:18 am #4399205

exis

Sorry I have made a typo on the step below. the default WPML language is ENGLISH

“When the installation finished we went to the pages and although we have set that the default WPML language is ENGLISH, the permalinks on the website are ?lang= el”

August 16, 2019 at 9:16 am #4405633

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the detailed information.

Now I understand what do you mean.

1. Can you please confirm that you have created a full backup of the current site?

2. Can I update the plugins and WordPress to the latest version?

Please let me know.

I will be waiting for your response.

PS: Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

August 16, 2019 at 10:40 am #4405845

exis

Yes, please go on

August 16, 2019 at 3:42 pm #4407389

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

That sounds great.

Thank you for the confirmation.

I will leave the ticket assigned to myself and I will get back to you at the beginning of next week.

Kind regards,
Mihai

August 16, 2019 at 7:50 pm #4407991

exis

In the meantime can we restore the database to have a working website?

August 19, 2019 at 4:47 pm #4417515

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Sure, please do that and let me know when that's done as I will be able to work on this only after you restore the database to the status that you want. Otherwise, we would risk having an issue if we both make changes in the DB at the same time.

I will be waiting for your response.

Kind regards,
Mihai

August 20, 2019 at 11:53 am #4423315

exis

Hello, database has been restored. Please proceed.