This thread is resolved. Here is a description of the problem and solution.

Problem: Unable to Update WPML


It was related to server cache. delete all wpml plugins manually and update them manually was fixed the issue.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by robertD-16 8 months, 3 weeks ago.

Assigned support staff: Riffaz.

Author Posts
September 9, 2019 at 11:21 am


Update WPML Plugins to current standard

I'm seeing the error
Fatal error: Class 'Twig_SimpleFunction' not found in /var/sites/d/ on line 30

/var/sites/d/ does not exist in the site. It was used for a short time when testing an upgrade issue with had with the site, When we were trying to determine if a parsing error came from WPML or with a SiteOrigin plugin. We have resolved the siteorigin issue but now cannot update or run WPML.

On the support section on WPML I have also noticed an error for memory_limit = 40m
but my pho.ini file reads memory_limit = 768M

Can you advise a way forward

Best Regards


September 9, 2019 at 12:00 pm #4536865


Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)


Thank you for contacting WPML support.

This error comes from /wp-content/plugins/wpml-translation-managementOLD/

And there is no any plugin named wpml-translation-managementOLD
So it should be because:
1. you renamed the Translation management for a backup and still your site is using the renamed or backed up plugin
2. and/or the migration or the installation is incomplete.

Please try following steps:
1. delete wpml-translation-managementOLD from your plugin directory via cPanel or FTP if you do not use it anymore
2. or move it to the out side of the site folder
3. or download it to you local machine if you need and then delete it.
4. download a fresh copy of WPML Translation Management from
5. install and activate it.

Deleting translation management plugin will not delete your translations or job.
Translations and jobs are saved in your database.

Let me know how it goes.


September 10, 2019 at 2:09 pm #4546277


Hi Riffaz
I can't see my email reply in this thread so I'll reiterate - I've attempted several times (it was the first thing I did), but I also followed it here

Can you have another asap please

September 10, 2019 at 2:11 pm #4546289


Hi Riffazz

This is now affecting all plugins - is there anything that can be done

September 11, 2019 at 6:46 am #4550921


Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)


I do not see that old translation management in your plugins directory: hidden link
So how is that possible you are still seeing this error message?
Do you have any server related caching setting?
Could you please check this in incognito mode?

I could not check your site as your login link does not work.

Let me know how we can proceed this further and the current error/issue you are having.


September 11, 2019 at 8:08 am #4551261



That's the core of the issue
Plugin updates failed. The old directorg does not exist but still generates this error

Apologies for no link I'm on a phone. Please use default login for address for WordPress if you get errors please tell me what they are

September 12, 2019 at 6:24 am #4558607


Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)


I installed translation management and your WPML plugins are updated to the latest versions and we are not seeing any error message now: hidden link

Hopefully, this is fine now.
This should have been a server related caching.
It's fine and works well now, by the way.

Let me know if you need anything else regarding this.


September 15, 2019 at 8:14 am #4574159


Apologies for the delay
Unfortunately we are unable to activate WPML Media
The error persists as
Fatal error: Class 'Twig_SimpleFunction' not found in /var/sites/d/ on line 30

September 15, 2019 at 10:08 am #4574287


My issue is resolved now. Thank you!