Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
The default site language is Hebrew, but the settings and the site itself display in English. Specifically, strings like 'Select Hotel' and 'executive' were not translating correctly despite being translated under strings previously.
Solution:
If you're experiencing this issue, we recommend disabling the Contact Form 7 plugin to check for conflicts. We then suggest installing our glue plugin, Contact Form 7 Multilingual, which enhances compatibility. This should allow strings to translate correctly even if the option 'look for strings while pages are rendered' is disabled. Please test this solution on your site.

If this solution does not apply because it might be outdated or not relevant to your case, we highly recommend checking related known issues at https://wpml.org/known-issues/, verifying the version of the permanent fix, and confirming that you have installed the latest versions of themes and plugins. If issues persist, please open a new support ticket at WPML support forum for further assistance.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Mateus Getulio 2 weeks, 6 days ago.

Assisted by: Mateus Getulio.

Author Posts
May 29, 2024 at 7:17 pm #15685289

Farhad

The default site is Hebrew. But in the settings + on the site itself it shows English.

For example, in the home page there are a few texts.

'Select Hotel','executive'

I translated it under strings. Before that everything was working fine and suddenly it went wrong

May 31, 2024 at 12:24 pm #15692224

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

Thank you for your patience while I investigated this issue. I was unavailable yesterday, that created a bit of a delay, I apologize for it.

Upon further review, it looks like the issue was fixed when I disabled the plugin Contact Form 7, it suggested it could be some conflict.

I went ahead and installed our glue plugin that increases compatibility: Contact Form 7 Multilingual.

After I did it, the strings are translated even if the option 'look for strings while pages are rendered' is disabled.

Can you please test it and confirm it is fixed?

Thank you,
Mateus

May 31, 2024 at 6:31 pm #15693782

Farhad

Thank You!

Farhad confirmed that the issue was resolved on 2024-05-31 18:31:16.
This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.