Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
The client expected the website to automatically display in German after selecting the language on the homepage, but the language did not change as expected.
Solution:
We recommend checking the language switcher options. The name of the language that appears in the language switcher is configurable. You can set the desired language by following the instructions on how to edit WPML's language table and adding your own languages using WPML's GUI. For detailed steps, please refer to the documentation: Editing WPML's Languages Table.

Please note that the solution provided might be irrelevant if it's outdated or not applicable to your case. If the issue persists, we highly recommend checking related known issues at https://wpml.org/known-issues/, verifying the version of the permanent fix, and confirming that you have installed the latest versions of themes and plugins. If you still need assistance, please do not hesitate to open a new support ticket with us.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Bruno Kos 1 month, 2 weeks ago.

Assisted by: Bruno Kos.

Author Posts
February 22, 2024 at 2:49 pm #15334224

kimberleyS

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got: hidden link

The website should automatically display in the language chosen.
If I choose on the homepage, the language in german, I should see thoughout the pages all in german.

Please help as we need to deliver this website to client!!
Many thanks
Lucia

February 22, 2024 at 3:12 pm #15334334

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch ) French (Français )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

I am not sure I see the issue - If I open hidden link, I see German content, if I open hidden link I see English.

Just as on the translated home page, etc.

Can you clarify a bit more?

Regards,
Bruno Kos

February 23, 2024 at 1:42 pm #15338007

kimberleyS

Hi Bruno, If I go to the website and select a language, I need all the pages to be displayed in the language I have chosen.

When you choose the language not defaulted, lets say German...and you go to another page it changes into English (default language)..We need this to be in German as the user has chosen that language...

So. If I enter the website, and I choose the Spanish language I want to see all the pages in the language that Ive chosen. Then If I enter Yolanda's page, I need to see that page in spanish as well, not in English. Because I've chosen spanish language at the beginning

I hope is clearer now, let me know if that can be fixed please.

February 23, 2024 at 2:43 pm #15338336

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch ) French (Français )

Timezone: Europe/Zagreb (GMT+02:00)

But isn't this about menus? If I open hidden link, I see that all menu items point to German properly, is this what you are after?

February 23, 2024 at 2:49 pm #15338344

kimberleyS

Hi Bruno, If you please choose the german version for example, and then you scroll down until the Bio's. Please choose Yolanda and you will see that that page is showing in English. I need it to be shown in german, because that's the language I've chosen at the beginning.

All the bio's pages are in English, not showing automatically the language I've chosen. That needs to be automatically.

Thanks

February 24, 2024 at 2:45 pm #15340597

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch ) French (Français )

Timezone: Europe/Zagreb (GMT+02:00)

So it would be "Zum profil" urls on hidden link?

Can you open the original home page and just resave it and then update the translation as well, so resave it as well? As I am not sure why only some URLS work, perhaps these got translated after the home page was translated.

If that doesn't work can you check this?
https://wpml.org/faq/how-to-translate-urls-shortcodes-and-html-attributes-using-the-advanced-translation-editor/#how-do-i-translate-urls-with-the-advanced-translation-editor

It may be needed depending on how you added these URLs there.

February 26, 2024 at 11:56 am #15343957

kimberleyS

Hi Bruno, Now I see the proper translation in along the pages..But on the main menu, you will see that all the languages we set up as ENG, DEU, ESP
But the ESP appears as "Español". We need it to be ESP

On the setting I see that its ok, but on the live website is incorrect.

Could you please help me with that?
thanks
Lucia

Screenshot 2024-02-26 at 12.55.46.png
February 26, 2024 at 4:09 pm #15345319

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch ) French (Français )

Timezone: Europe/Zagreb (GMT+02:00)

What appears in language switcher (the name of the language) comes from here:
https://wpml.org/documentation/getting-started-guide/language-setup/editing-wpmls-languages-table/#adding-your-own-languages-using-wpmls-gui

It is that "Translation (language)" field where you can set ESP.

February 26, 2024 at 4:21 pm #15345343

kimberleyS

Hi Bruno, that setting was done..But still don't see the the language the way we want to display it..could you fix that please?

Screenshot 2024-02-26 at 17.19.17.png
February 27, 2024 at 7:36 am #15347428

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch ) French (Français )

Timezone: Europe/Zagreb (GMT+02:00)

Would you be willing to provide me with WordPress and FTP credentials so I could investigate the issue directly?

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

I marked your next reply as private so that you can safely add credentials.

February 27, 2024 at 8:50 am #15347750

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch ) French (Français )

Timezone: Europe/Zagreb (GMT+02:00)

If I set it here for Translation (Spanish) hidden link it works.

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.