This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
September 27, 2018 at 12:12 pm #2770423

jhonny-luisA

Hi,

i created a multilingual site: hidden link Im wondering how i can make the sub pages name have switched automatically in the given language. For example, the pages About Us, Our Services, Contact, Portfolio, id like them to appear in french, german, spanish, italian, automatically once the customer chooses his preferred language. i followed your blog where everything was clearly explained. I set up all the subpages in the various languages, content is already translated, pages exist and everyhting was linked. However, nothing appears on site.

September 28, 2018 at 7:58 am #2772794

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

However, nothing appears on site.

Can you please elaborate a little more so I can better understand? I can see that the homepage is showing perfectly and If I view the about page & it's translation I can view it properly.

Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Look forward to your reply.

Thanks

September 30, 2018 at 8:58 am #2776347

jhonny-luisA

Please find attached the screenshot which explains better my problem. I've created with WPML a multilingual site in German, French, Spanish, Italian and English. All pages are translated and exists already. 1 week ago i managed to link them all together (See screenshot). However, somehow (i dont know what happened) I dont see the pages and translations linked anymore. I just see the plain english version and just 1 landing page, even the english sub pages such as "About Us", "Services", "Portfolio", "Contact Us" pages are not linked.

What can i do to fix that issue. Please dont send me any blogs or links, i already tried everything out.

October 1, 2018 at 2:54 am #2777084

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Ok, now I understand that your menu links are missing, would you mind providing me login details so I can quickly check your settings and suggest you feedbacks?

I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues needs some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

October 1, 2018 at 7:32 am #2777266

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

To fix the issue, please follow the below steps:
- Go to Zephyr->Theme Options
- Go to Page Layout
- Go to Default -> Header
- Choose the header you wanted to display

Let me know if this helps.

Thanks

October 6, 2018 at 1:37 pm #2792845

jhonny-luisA

Hi,

i just realized that at top of my website the following words are displayed: E-BAUS</>strong>. Please find screenshot attached, which shows this issue. Id like to remove the coding .... and just have E-BAUS written there. Strange is that for the french version its showing up like this but on the english version its appearing normal. The same issue i have with German and also spanish version.

English: hidden link
French: hidden link

Please let me know how i can remove that or please do it yourself.

Thanks,
Jhonny

October 8, 2018 at 5:00 am #2794775

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Please follow the below steps:

- Go to Zephyr->Header
- Edit the title and disable the Bold Option
- Update both languages.
- Edit the title and Enable the Bold Option again
- Update both languages.

Let me know if this helps.

Thanks