Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 18:00 9:00 – 18:00 9:00 – 18:00 9:00 – 18:00 9:00 – 18:00 -
- - - - - - -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 3 replies, has 2 voices.

Last updated by Waqas Bin Hasan 2 months, 2 weeks ago.

Assisted by: Waqas Bin Hasan.

Author Posts
December 6, 2023 at 3:00 pm #15008969

vibekeO

hi,
We had 2 languages and 2 currencies installed on the site, but decided to remove a language. Now we only use 2 currencies and place them on the site using WooCommerce Multilingual & Multicurrency. But the issue is that sometimes the widget does not show (does not show on product sites) and on meny it only showes on the front page, not other sites.
And on top of that, when choosing currency (the second one) the prices are not correct. We have set prices on the products as we can not use a currency calculator. But how come the prices that are showed are wrong?

December 8, 2023 at 10:00 am #15024209

Waqas Bin Hasan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting the support.

Before proceeding further, may I ask you to try the following?

IMPORTANT: Take full backup of your website and database beforehand. It is highly advised to try the following on a staging/dev site first, so your live website isn't compromised.

- Update WordPress to the latest version.
- Switch to a standard WordPress theme like 2021 or 2023 because YOOtheme isn't compatible with WPML (https://wpml.org/theme/yootheme/). So it is better to check if problem is really with WPML.
- Deactivate all plugins except WPML, WCML and WooCommerce and check for the issue.
- Activate each plugin one-by-one, while keeping check on the issue after a plugin is activated. This way you'll be able to pinpoint a plugin having a conflict (or problem), if any.

If you see that another theme works fine, I'll advise to contact the YOOtheme support for a compatibility update.

Theme and plugin authors are welcome to join WPML’s Go Global program, which helps them make their code multilingual ready. Together with WPML’s compatibility team, they can test and confirm that their theme or plugin works with WPML. See https://wpml.org/documentation/support/go-global-program/ for details and you can refer your theme/plugin provider to this as well.

Regards.

December 11, 2023 at 9:12 am #15034273

vibekeO

I know that the theme is not ideal, and we are hoping to move the site over to a theme that is supported in 2024.
But that also means that I cannot update the theme. I will try to change to a standard theme and see if it works then.

December 11, 2023 at 12:36 pm #15037003

Waqas Bin Hasan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Sure, please take your time and let me know your findings when you're ready.

The topic ‘[Closed] Only use multicurrency and not language’ is closed to new replies.