Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Diego Pereira 1 month, 4 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
January 12, 2021 at 2:04 pm #7826021

andreyK-12

Hi!

I have a variable subscription product which is also digital and downloadable. I need to set different download link for it's translation. I found this ticket from 2017: https://wpml.org/forums/topic/translating-download-link-of-digital-product/

It says:
In the translation editor interface you will see a section called "Downlaod files" with the field for the name and for the file URL. You can change it there according to your needs.

I enabled "Add separate download files for translations when translating products", here is a screenshot: hidden link

The problem is that I don't have this "Download files" section is translation editor interface. Check the screenshot.

What am I doing wrong?

2021-01-12_17-02-45.png
January 12, 2021 at 3:40 pm #7827107

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello, welcome to the WPML support Forum!

Could you please try to search the download URL using the "search source" field? Please check these links for more details:
- https://wpml.org/forums/topic/advanced-translation-editor-edit-a-alink-tag-on-the-fly-for-new-language/
- https://wpml.org/announcements/2020/02/translating-links-with-advanced-translation-editor/

Please let us know if it worked for you.

January 12, 2021 at 4:36 pm #7827655

andreyK-12

No, it didn't work 🙁

2021-01-12_19-35-58.png
January 12, 2021 at 8:23 pm #7829389

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Please send us access to your WordPress dashboard (website URL, login and password) and FTP credentials (important). I'll check and do some tests. - Please use the private field to send the sensitive data - do not post if you do not see it.

It would be better if you give me a test site rather than the live site.

IMPORTANT: Please backup a working copy of site files and database before.

Maybe I'll need to replicate your site locally. For this, please install these plugins:
Duplicator:
 https://wordpress.org/plugins/duplicator/

File Manager:
 https://wordpress.org/plugins/wp-file-manager/

All-in-one WP Migration
 hidden link

 This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please let me know if this is ok for you.

January 13, 2021 at 6:10 pm #7838019

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks! I did some tests and noticed that it works correctly with the Classic Translation Editor, but not with the Advanced Translation Editor (ATE).

I noticed that the same issue happens on a clean install, so I'm escalating the issue to our ATE team.

We will send you a feedback soon.

July 28, 2021 at 1:33 pm #9299995

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

(updating ticket status)