This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by janL-28 3 weeks, 2 days ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
September 16, 2019 at 9:44 am

janL-28

Hi,

We have following translation issue.

When trying to edit the German translation of e.g. the post "5 Reasons To Use Hair Extensions On Your Wedding Day", it does not display the correct Media content of the English version (see attached "WPML Media Translation").

hidden link

As you can see from following 2 screenshots (Media English Content & Media Translation), it shows the correct English content, however does not display it correctly in WPML Media Translation.

I assume this issue is for all posts, pages, etc.

Please advise.

Thanks,
Jan

September 16, 2019 at 7:55 pm #4583701

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Before proceeding with a more detailed and accurate reply I would need some more details from you. Which issue do you see? I took a detailed look in your WordPress Dashboard and noticed the Translation Editor for the '5 Reasons To Use Hair Extensions On Your Wedding Day' shows exactly the sample picture you have in your media library for English German. Can you please, provide me with the full details of what you need to achieve here? Thank you for your collaboration and patience, have a nice day.

September 17, 2019 at 6:27 am #4585805

janL-28

Hi,

Please check the screenshot "WPML Media Translation.png".

There you can see that the positions "Title" and "Alt Text" do not display the correct content according to the content of the images in Media Library.

Best regards,
Jan

September 17, 2019 at 2:17 pm
September 17, 2019 at 2:18 pm #4589113

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Jan,

Please, take a look at my private reply above. Thanks!

September 19, 2019 at 6:28 am #4601663

janL-28

Hi,

Migration process is finished, here the weblink: hidden link

Thanks,
Jan

September 19, 2019 at 8:04 pm #4608213

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Jan,

Thank you for the updates. I checked your website using the migrated copy and noticed the media text content works as expected in new posts as you can check it at Posts > WPML Test Post, I tested it uploading the media directly in the Media Library and in the post as well, in the two scenarios it works as expected.

In case of existing posts I noticed if you add a test image for it, update the post and then click to edit the translation it will also work as expected, all the media text content will reflect the same text you entered for them in the Media Library or during the upload process as you can check at Posts > 5 Reasons To Use Hair Extensions On Your Wedding Day. It is not clear to me what cause the initial issue, it seemed to be some cache behavior, in any case it is now fixed.

Please, let me know if you need any further clarifications and instructions, have a nice day.

September 23, 2019 at 8:52 am #4621815

janL-28

Hi,

With which username and password can I access the migrated website in order to verify?
hidden link

Thanks,

September 23, 2019 at 12:52 pm #4624117

janL-28

Hi,

Ok, got it regarding username and password, same as for original version.

Following point makes no sense:

In the English version of WPML Test Post, there are in total 5 images. However, when editing the German translation of this post, it only shows 3 images. How is this possible?

Thanks,
Jan

September 23, 2019 at 12:55 pm #4624125

janL-28

And what do I have to do so it will also be correct in the version of our server?

September 23, 2019 at 9:51 pm #4626753

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. As regarding the 'WPML Test Post' the cause the issue might be a server specific issue as we have some issues with our test CloudWays environment. The same doesn't happen for your post '5 Reasons To Use Hair Extensions On Your Wedding Day' in your website. For example, I updated it and now it shows the images text content properly in the WPML Classic Translation Editor.

In order to apply the same fixes for your other posts you can try the following in your website:

1 - Click to edit your posts in the default language and make some minor editing on it, you can add a period for example or an empty space and save it, the point here is just to refresh the translations jobs in the database.

2 - Click to edit the translation using the WPML Classic Translation Editor (you can choose it from your WordPress Dashboard > WPML > Settings > How to translate posts and pages settings).

You will notice once the steps above are made, the translation jobs are refreshed and you will see the correct number of images with the correct text content (title, alt and description texts).

Please, let me know if it solves your issue of if any additional instructions and clarifications are needed, have a nice day.

September 25, 2019 at 3:44 pm #4640711

janL-28

My issue is resolved now. Thank you!