Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by Lauren 8 months ago.

Assisted by: Lauren.

Author Posts
August 8, 2023 at 2:42 pm #14170161

romainO-2

Divi video icon showing different in second language

August 9, 2023 at 9:21 pm #14178373

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I think I found where the issue is coming from. Using String Locator plugin, I found in wp-content/et-cache/68/et-core-unified-68.min.css the line that shows this:

@media only screen and (min-width:1350px){.et_pb_row{padding:27px 0}.et_pb_section{padding:54px 0}.single.et_pb_pagebuilder_layout.et_full_width_page .et_post_meta_wrapper{padding-top:81px}.et_pb_fullwidth_section{padding:0}}.et_pb_video_0 .et_pb_video_overlay .et_pb_video_play:before{font-family:ETmodules!important;font-weight:400!important;content:"i"!important}.et_pb_video_0 .et_pb_video_overlay_hover:hover{background-color:rgba(0,0,0,.6)}

The "i" should be "\49". I used the String Locator plugin to change this and now the icon looks correct on the frontend: hidden link

You can manually change it, but I'm afraid an update from Divi will override the changes. So, I think you should submit this find to Divi so that they can resolve the issue in their files. In the meantime, changing this should resolve the issue as a workaround.

Please let me know if you need any further assistance and I will be happy to help.

August 10, 2023 at 8:19 am #14180035

romainO-2

Hello Lauren,

Thank you for your investigation.
I can talk to the ET teal about this issue but it's not clear what I have to explain. The issue only appear when using WPML. I don't understand why the problem should be corrected on their side.

August 15, 2023 at 3:33 pm #14204157

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have escalated this ticket to our compatibility team so that they can get in touch with the Divi team and find a permanent fix for this. I'll let you know if I receive any new information.

August 15, 2023 at 3:45 pm #14204225

romainO-2

Ok thank you !

August 15, 2023 at 5:36 pm #14204593

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

You are welcome, hopefully I will have an update for you soon.

August 17, 2023 at 8:31 pm #14248719

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please go to WPML -> Settings and click the Custom XML Configuration tab. Add the following to register the icon code:

<wpml-config>
	<shortcodes>
  	<shortcode>
    	<tag>et_pb_icon</tag>
    </shortcode>
  </shortcodes>
</wpml-config>

Then create a new test post and let's check to confirm if the icon shows as expected in both languages. Please let me know the results.

August 18, 2023 at 8:59 am #14250875

romainO-2

Hello
I have just tried and it seems to solve the problem
Thank you

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.