Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 12 replies, has 2 voices.

Last updated by Dražen Duvnjak 1 year, 3 months ago.

Assisted by: Dražen Duvnjak.

Author Posts
January 24, 2023 at 9:57 am #12879069

tristanv-2

My website (growth-center.nl) uses two different domains (.com for English and .nl for Dutch). I am trying to make a change to the English version of a page, but since the Dutch version is in the lead, I can't use divi builder.

I am also unable to connect the existing English translation to the original Dutch version of the page.

This makes it impossible to edit the English version of the page.
How can I connect the existing English translation to my Dutch page?

January 26, 2023 at 7:12 am #12895081

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for your patience.

Can you please try the next steps and let me know how it goes:

1) Does the backed Divi builder works for you? Because there are some issues and depending on your hosting limits, Divi Visual or Divi backed builder might not work.

- https://wpml.org/errata/a-different-domain-per-language-configuration-conflicting-with-the-divi-editor/

2) Does the issue still happens on a new page, or all or only specific?

3) Please make a backup before proceeding.

Does the issue still happen if you only leave WPML plugins active, and all others disabled?

Thanks,
Drazen

January 29, 2023 at 9:30 am #12911045

tristanv-2

Hi Drazen,

Somehow my previous reply got lost and doesn't show up.
Here are my anwers:

1) No it doesn't. None of the editors work.
2) It happens on new pages as well (I created hidden link to test this)
3) It happens with all other plugins disabled as well.

Thanks,
Tristan

January 30, 2023 at 6:29 am #12918509

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello Tristan,

thanks for getting back.

Please make a full backup of your site (files and database) and confirm it in your next reply.
If possible please provide access to the staging website, not production.

Please note, that I might need to do some debugging procedures like enable/disable plugins, switch themes, change the default language of the user account, and/or access your website database to debug the issue furtherly.

I will share with you any changes or steps done in this process. Please let me know if you do not agree with the above or if I do not have your permission for any.

I would need to access both your site's wp-admin and FTP account, if possible.

I have enabled the private username and password fields in your next reply.

I suggest you create a new user, set it as an administrator and then add those credentials in the private fields mentioned.

You can safely add your information into these fields.

Thanks,
Drazen

January 30, 2023 at 7:22 am #12918767

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back.

I see the problem, you are not logged in in 2nd domain, while you should be. I think it could be related to your server/domain settings and in order to confirm and check further I would like to migrate a copy to our server.

Let me know if that is okay.

Regards,
Drazen

January 30, 2023 at 7:55 am #12918879

tristanv-2

Sure, go ahead

January 30, 2023 at 10:08 am #12919965

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks.

I have migrated the website and test on our hosting and it works just fine. Video attached.

- hidden link

The problem that is causing this for you is that you are not logged in to your 2nd domain, it could be related to hosting, domain settings and etc.

- https://wpml.org/documentation/getting-started-guide/language-setup/passing-session-data-between-languages-in-domains/

Since it works from our side, the best I can suggest is further checking with domain/hosting support, try on another server, disabling all plugins (must use also), logging out, then logging back in and checking if you are logged in correctly to 2nd domain. To be fair very difficult to say what is wrong, since it works fine on our side and is specific to your settings, hosting or similar.

Please check and let us know how it goes and if there is anything else we can do to help.

Regards,
Drazen

January 30, 2023 at 11:54 am #12921241

tristanv-2

Hi Drazen,

How can I login to the second domain?

January 30, 2023 at 12:02 pm #12921269

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

as explained in my reply and shown in the video, it should happen automatically when the automatic login option is enabled (WPML > Languages), which it is on your site.

It works fine on the test server, so as explained I suspect it could be related to your environment and configuration, so the best would be to check further as advised.

Please check and let me know if there are any doubts about my previous reply.

Regards,
Drazen

February 6, 2023 at 3:02 pm #12969511

tristanv-2

Hi Drazen,

With your help the issue is now almost resolved.
The website host disabled 'primary redirects' on my website and I am now able to log into both domains again.

There is however a new issue:

Dutch pages direct correctly to English pages using the 'flag' in the top right corner.
English pages however, direct to the correct Dutch url, but substitute '.nl' for '.com'.

E.g.
hidden link should point to hidden link. nl/over/ but instead points to hidden link .com/over/.

This goes for all pages.
The .com home page points to growth-center.com when using the flag (which makes sense considering the above).

Could you help me solve this problem?

February 6, 2023 at 3:35 pm #12969737

tristanv-2

Hi Drazen,

Unfortunately the issue isn't resolved.
I am not sure why but I am no longer able to be logged into both domains at the same time (.com and .nl). I was able to previously though.

And for some reason not all changes made to translations (using 'edit translations') are reflected on the website. Please see hidden link as an example.

You have active credentials for the website. Feel free to login and see for yourself.

Thanks for your support,
Tristan

February 6, 2023 at 3:39 pm #12969785

tristanv-2

If you click the link in my previous reply, you will find that the WPML functionality is broken:
the site will direct you to a combination of the English and Dutch url: hidden link while it should point to hidden link.

The Dutch version is: hidden link

So the website somehow is making combinations of the two domains.

February 7, 2023 at 6:53 am #12974107

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello Tristan,

thanks for getting back.

Please note, we limit 1 issue per 1 ticket, to keep things clear and easy to follow. If you have any other issues like the one you mentioned: translations, and link broken please open a new ticket for each and we will be glad to help.

As for the current topic of the ticket and issue reported, I just checked and could login to both domains, works just fine for me. Image attached.

Please check again, or try in a private window.

Regards,
Drazen

Screenshot_1.jpg
This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.