This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Riffaz 1 month, 1 week ago.

Assigned support staff: Riffaz.

Author Posts
February 24, 2020 at 2:15 am #5550363

juhaL-2

I want to have the divi builder language in English in every case. Now it is forcing to translate the builder to Swedish under the pages that are in Swedish. This is really annoying.
I have wordpress admin language english and I want to have divi builder language as well.
I have been contact to DIVI elegant themes support as well, but without any luck. They told me to use the String method..

https://wpml.org/documentation/getting-started-guide/string-translation/

I have tried this as well. I need all the text in divi editor to be in Swedish.

I have been stuck with this many days. Please disable the translation in DIVI editor.

February 24, 2020 at 4:32 am #5551363

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

You can change your backend language from Users>Your Profile Language : hidden link

This select field will specify the language used for your backend. Please note that this will be only applied to your user.
If you want to browse your backend in a different language with a different user, you'll need to edit his profile to specify this.
Otherwise, the backend should be displayed in the language you used to install WordPress.

Anyhow, if you are using the FRONT-END builder (eg : elementor front end builder or Divi Front end builder), this is the expected behavior and the way things work is: due to the fact that Elementor/Divi is a front-end editor, it uses the language of the front end, it does not matter what setting you choose, the Elementor/Divi panel elements use the same language as the language of the page you are editing.
This is how the page builders work.

So what you are asking is simply not possible at the moment.

Here a user says these steps make the front-end stays in English: https://wpml.org/forums/topic/elementor-interface-displays-in-edited-language/#post-3556427
Try and see but this is something we did not try to check fully yet.

Regards,
Riffaz.