This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 3 voices.

Last updated by rezaK-6 2 weeks, 5 days ago.

Assigned support staff: Noman.

Author Posts
September 26, 2019 at 1:42 pm #4647295

rezaK-6

Tell us what you are trying to do?
I want to add language switcher to navigation menu

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?
hidden link

September 26, 2019 at 1:50 pm #4647365

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @rezak-6, welcome to the WPML support Forum!

Please check these links to see how to add a language switcher:
- https://wpml.org/documentation/getting-started-guide/language-setup/#language-switcher
- https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

Please let me know if it worked for you.

All the best,
Diego

September 26, 2019 at 1:54 pm #4647371

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. You can add language switcher in your site menu from WPML >> Languages > Menu Language Switcher.

Here is doc for more details:
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

September 26, 2019 at 2:02 pm #4647405

rezaK-6

Hi i have followed the same instructions but not working

September 26, 2019 at 5:09 pm #4649221

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Could you please follow these steps in order to isolate the cause of the issue:
1. Backup your site first before making any change, this is for security reasons.
2. Deactivate all the plugins that are not related to WPML.
3. Switch for a moment to a WordPress default theme like Twenty Seventeen.
4. If the issue is gone, activate one by one to see which one there is an interaction issue.
5. If the issue still persists, please provide temporary access (WP-Admin and FTP Login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

September 27, 2019 at 3:32 pm #4655617

rezaK-6

My issue is resolved now. Thank you!