Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Christopher Amirian 10 months ago.

Assisted by: Christopher Amirian.

Author Posts
June 9, 2023 at 5:21 am #13796623

romainO-2

Bonjour,

L'édition de projets dans différentes langues (en utilisant l'éditeur wordpress) cause aléatoirement des erreurs : Internal server error

L'erreur est identique à celle reportée ici : https://wpml.org/fr/forums/topic/erreur-500-regulieres-sur-le-site/

Voici quelques infos des logs du serveur :

[Thu Jun 08 20:40:23 2023] [error] [client 51.222.253.20] [host hidden link; AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

[Thu Jun 08 21:33:47 2023] [error] [client 2a02:8428:e55a:6401:2883:150b:5c41:e2cd] [host hidden link; AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: hidden link

Le fichier htaccess a été nettoyé et réduit au minimum.

Je suis en train de dupliquer le site sur un autre serveur pour qu'on puisse faire des tests.

Romain

June 9, 2023 at 5:51 am #13796647

romainO-2

Lorsque l'erreur apparait, la simple ouverture de la page des permaliens suffit à la supprimer : hidden link

June 9, 2023 at 6:58 am #13797047

romainO-2

J'ai fait des tests en réactivant un par un les plugins. Le problème ne semble pas être dû à un plugin en particulier. Par contre le site ne bugue plus quand on désactive WPML.

June 11, 2023 at 8:46 am #13804699

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

This is the English language forum. If you are interested in continuing in French please open up a ticket here:

https://wpml.org/fr/forums/forum/assistance-en-francais/

If you wish to continue in English:

Please update WPML and WPML Add-ons to the latest version:

- IMPORTANT STEP! Create a backup of your website. Or better approach will be to test this on a copy/staging version of the website to avoid any disruption of a live website.
- Go to "WordPress Dashboard > Plugins > Add new > Commercial (tab)".
- Click the "Check for Updates" button.
- Update WPML and its addons there.

For more information:
https://wpml.org/faq/install-wpml/#automated-updates

After that please re-save the permalinks to see the result.

Also, you mentioned that you wanted to test the website on another server. What was the result for that?

Thanks.

June 12, 2023 at 2:29 pm #13810631

romainO-2

Hello Christopher,

It's ok with the english support, as soon as we find a solution.
I have duplicated the website here and was able to reproduce the error : hidden link
Here is a video showing the error : hidden link

I can give you full access of this development site and you can do any modification you want.
I have tried to update WPML but it broke the site. So I have loaded again the backup and let you do any update you want 🙂

Tell me what you need for us to be efficient.

Romain

June 13, 2023 at 12:44 pm #13817197

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi Romain,

yes please share the login information and if you can FTP info for the test website so that we can check.

Make sure you set the next reply as private.

Thanks.

June 13, 2023 at 2:21 pm #13818117

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

Even now I can not access the login page and it throws the Error 500 one.

Would you please contact the hosting service provider and ask what is the error under the hood?

Also for a starter I'd appreciate it if you could do the steps below:

The minimum requirement is 128M but I suggest that you increase it to 512M: https://wpml.org/home/minimum-requirements/

You can add this by adding the code below to "wp-config.php" file of your WordPress installation root folder:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

Please add the code above the line below:

/* That's all, stop editing! Happy blogging. */

Thanks.

June 13, 2023 at 2:46 pm #13818385

romainO-2

Ok Memory Limit : done.

500 Error : removed, just opening the permalinks setting page, like I told you.

The response of my hosting service :
Je viens de vérifier le bon fonctionnement de vos services et je vous confirme qu'aucun incident n'est constaté sur nos infrastructures à notre niveau.

Votre demande dépassant le cadre des services que nous fournissons à nos clients, je vous informe que notre support ne peut vous accompagner sur ce sujet.

Cependant je peux vous inviter à procéder à une restauration des fichiers, si ce dysfonctionnement est récent.
Pour cela, je vous invite à suivre le guide OVHcloud suivant : hidden link

J'en profite également pour vous fournir un guide permettant de diagnostiquer un code 500 : hidden link

June 14, 2023 at 6:36 am #13821627

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi Romain,

The fact that the issue is happening even on the login screen shows that it might be possible that the issue is even not related to WPML.

The OVH could at least give the error behind the error 500 to know if it was a PHP error or not.

Anyways, I logged in to the website and did a few tests but the issue did not happen.

The best way to go forward is to determine if the issue even happens if you check it on another server.

I can try to copy your website to our server if you allow us (if the website is under 1 GB) and you can do some tests there.

There are two other tests that needs to be checked:

- IMPORTANT STEP! Create a backup of your website. Or better approach will be to test this on a copy/staging version of the website to avoid any disruption of a live website.
- Switch to the default theme such as "TwentyTwenty" by going to "WordPress Dashboard > Appearance > themes".
- Go to "WordPress Dashboard > Plugins" and deactivate all plugins except WPML and its add-ons.
- Check if you can still recreate the issue.

The test above isolates WPML to see if the issue is still there.

The other test is to have the vice versa, that is, deactivating all WPML plugins and having other plugins enabled. See if the same thing happens.

The nature of randomness of the error 500 and the fact that even the login screen sometimes throws the same error makes it necessary to do the tests above to narrow that the issue.

Thanks.

June 14, 2023 at 12:41 pm #13825243

romainO-2

Hello Christopher,

I have asked the hosting service for more information about the 500 error.

The website is more than 6Go. But you can do any test on this website : hidden link , even crashing it, no problem, it's a copy for testing.

- Switch to the default theme such as "TwentyTwenty" by going to "WordPress Dashboard > Appearance > themes". -->Actually the error occurs almost only when visiting projects and the "All projects" page. So I need to keep Divi activated.

- Go to "WordPress Dashboard > Plugins" and deactivate all plugins except WPML and its add-ons. Check if you can still recreate the issue. --> I was not able to recreate the issue.

- The other test is to have the vice versa, that is, deactivating all WPML plugins and having other plugins enabled. See if the same thing happens. -->No issue, until I activate WPML.

Don't you think it seems to look like some kind of server overload problem ? Since you made me change the memory limit, the error seems to be less frequent.

Romain

June 14, 2023 at 1:31 pm #13825581

romainO-2

Solution : https://wpml.org/errata/htaccess-is-rewritten-with-language-folder/

June 15, 2023 at 5:12 am #13829035

Christopher Amirian
Supporter

Languages: English (English )

Timezone: Asia/Yerevan (GMT+04:00)

Hi there,

Thank you for sharing the solution you have found for the issue.

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.